Blackbaud Fundraiser Performance Management and Guided Fundraising Login
Incident Report for Reeher
Resolved
A global issue with Microsoft/Azure AD has been resolved. Thank You for your patience.
Posted Sep 28, 2020 - 18:23 CDT
Investigating
We are currently investigating an issue with the Blackbaud Fundraiser Performance Management and Blackbaud Guided Fundraising Login. We will post more information on this page as it becomes available.
Posted Sep 28, 2020 - 17:35 CDT
This incident affected: Blackbaud Fundraiser Performance Management and Blackbaud Guided Fundraising.