Blackbaud Guided Fundraising & Fundraiser Performance Management outage
Incident Report for Reeher
Resolved
We have confirmed that authentication services have returned and you may login now. If you continue to encounter errors please let us know. Thank you for your patience.
Posted Sep 28, 2020 - 20:18 CDT
Identified
We have identified the issue as a global outage with Microsoft Azure AD services. We are working with Microsoft to resolve this issue, thank you for your patience.
Posted Sep 28, 2020 - 18:59 CDT
This incident affected: Blackbaud Fundraiser Performance Management and Blackbaud Guided Fundraising.