Blackbaud Guided Fundraising
Incident Report for Reeher
Resolved
This incident has been resolved.
Posted Sep 24, 2020 - 13:49 CDT
Update
Blackbaud Guided Fundraising never experience an outage from the investigation that we have conducted. If you did experience an outage please reach out to Support to inform them. Thank You.
Posted Sep 24, 2020 - 13:49 CDT
Investigating
We are currently investigation an issue with Blackbaud Guided Fundraising. We will post more information on this page as it becomes available.
Posted Sep 24, 2020 - 10:31 CDT
This incident affected: Blackbaud Guided Fundraising.