Fundraiser Performance Management Login
Incident Report for Reeher
Resolved
This incident has been resolved.
Posted May 08, 2020 - 13:55 CDT
Update
We are continuing to investigate this issue.
Posted May 08, 2020 - 11:56 CDT
Investigating
We are currently investigating a login issue with Fundraiser Performance Management and Guided Fundraising impacting some users. If you receive the error page while logging in, please try clearing your cache. We will post more information on this page as it becomes available.
Posted May 08, 2020 - 11:50 CDT
This incident affected: Blackbaud Fundraiser Performance Management and Blackbaud Guided Fundraising.