Fundraiser Performance Management and Guided Fundraising Login
Incident Report for Reeher
Resolved
This incident has been resolved.
Posted Jun 30, 2020 - 11:38 CDT
Investigating
We are currently investigating a login issue with Fundraiser Performance Management and Guided Fundraising. We will post more information on this page as it becomes available.
Posted Jun 30, 2020 - 10:17 CDT
This incident affected: Blackbaud Fundraiser Performance Management and Blackbaud Guided Fundraising.