Fundraiser Performance Management Login
Incident Report for Reeher
Resolved
This incident has been resolved.
Posted May 14, 2020 - 14:31 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 14, 2020 - 13:43 CDT
Update
We are continuing to investigate this issue.
Posted May 14, 2020 - 13:12 CDT
Investigating
We are currently investigating a login issue with Fundraiser Performance Management. We will post more information on this page as it becomes available.
Posted May 14, 2020 - 13:08 CDT
This incident affected: Blackbaud Fundraiser Performance Management.