Blackbaud Guided Fundraising
Incident Report for Reeher
Resolved
This problem has been resolved.
Posted Mar 21, 2020 - 17:51 CDT
Investigating
We are currently investigation an issue with Blackbaud Guided Fundraising. We will post more information on this page as it becomes available.
Posted Mar 21, 2020 - 13:51 CDT
This incident affected: Blackbaud Guided Fundraising.