Blackbaud Guided Fundraising
Incident Report for Reeher
Resolved
This incident has been resolved.
Posted Apr 10, 2020 - 16:21 CDT
Investigating
We are currently investigation an issue with Blackbaud Guided Fundraising. We will post more information on this page as it becomes available.
Posted Apr 10, 2020 - 12:54 CDT
This incident affected: Blackbaud Guided Fundraising.