Fundraiser Performance Management Login
Incident Report for Reeher
Resolved
This incident has been resolved.
Posted Apr 30, 2020 - 11:30 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 30, 2020 - 11:02 CDT
Investigating
We are currently investigating a login issue with Fundraiser Performance Management. We will post more information on this page as it becomes available.
Posted Apr 30, 2020 - 09:57 CDT
This incident affected: Blackbaud Fundraiser Performance Management.