Blackbaud Fundraiser Performance Management Login
Incident Report for Reeher
Resolved
This incident has been resolved.
Posted Feb 24, 2020 - 14:13 CST
Investigating
We are currently investigating an issue with the Blackbaud Fundraiser Performance Management. We will post more information on this page as it becomes available.
Posted Feb 24, 2020 - 14:00 CST
This incident affected: Blackbaud Fundraiser Performance Management.