Blackbaud Fundraiser Performance Management Login
Incident Report for Reeher
Resolved
This incident has been resolved.
Posted Mar 25, 2020 - 07:17 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 24, 2020 - 08:33 CDT
Investigating
We are currently investigating an issue with the Blackbaud Fundraiser Performance Management Login. We will post more information on this page as it becomes available.
Posted Mar 23, 2020 - 13:32 CDT
This incident affected: Blackbaud Fundraiser Performance Management.