Blackbaud Fundraiser Performance Management Login
Incident Report for Reeher
Resolved
This incident has been resolved.
Posted Feb 10, 2020 - 15:27 CST
Update
We are continuing to investigate this issue.
Posted Feb 10, 2020 - 14:33 CST
Investigating
We are currently investigating an issue with the Blackbaud Fundraiser Performance Management Login. We will post more information on this page as it becomes available.
Posted Feb 10, 2020 - 14:30 CST
This incident affected: Blackbaud Fundraiser Performance Management.