Fundraiser Performance Management - Login Issues
Incident Report for Reeher
Resolved
This incident has been resolved.
Posted Feb 04, 2020 - 10:35 CST
Update
We are currently investigating a login issue with Fundraiser Performance Management. We will post more information on this page as it becomes available.
Posted Feb 04, 2020 - 10:28 CST
Update
We are continuing to investigate this issue.
Posted Feb 04, 2020 - 10:25 CST
Investigating
We are currently investigating reports of slow performance.
Posted Jan 28, 2020 - 11:19 CST
This incident affected: Blackbaud Fundraiser Performance Management.