Blackbaud Fundraiser Performance Management Login
Incident Report for Reeher
Resolved
This incident has been resolved.
Posted Jun 01, 2020 - 12:58 CDT
Investigating
We are currently investigating an issue with the Blackbaud Fundraiser Performance Management Login. We will post more information on this page as it becomes available.
Posted Jun 01, 2020 - 12:01 CDT
This incident affected: Blackbaud Fundraiser Performance Management.