Blackbaud Fundraiser Performance Management Login
Incident Report for Reeher
Resolved
This incident has been resolved.
Posted Apr 10, 2020 - 16:21 CDT
Investigating
We have identified an issue impacting some of our customers. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. Please continue to reference this page for updates.
Posted Apr 10, 2020 - 15:57 CDT
This incident affected: Blackbaud Fundraiser Performance Management.